Codeforces 292 D. Connected Components (并查集)

Description

We already know of the large corporation where Polycarpus works as a system administrator. The computer network there consists of n computers and m cables that connect some pairs of computers. In other words, the computer network can be represented as some non-directed graph with n nodes and m edges. Let’s index the computers with integers from 1 to n, let’s index the cables with integers from 1 to m.

Polycarpus was given an important task — check the reliability of his company’s network. For that Polycarpus decided to carry out a series of k experiments on the computer network, where the i-th experiment goes as follows:

  1. Temporarily disconnect the cables with indexes from li to ri, inclusive (the other cables remain connected).
  2. Count the number of connected components in the graph that is defining the computer network at that moment.
  3. Re-connect the disconnected cables with indexes from li to ri (that is, restore the initial network).

Help Polycarpus carry out all experiments and for each print the number of connected components in the graph that defines the computer network through the given experiment. Isolated vertex should be counted as single component.

 

Input

The first line contains two space-separated integers n, m (2 ≤ n ≤ 500; 1 ≤ m ≤ 10^4) — the number of computers and the number of cables, correspondingly.

The following m lines contain the cables’ description. The i-th line contains space-separated pair of integers xi, yi (1 ≤ xi, yi ≤ n; xi ≠ yi) — the numbers of the computers that are connected by the i-th cable. Note that a pair of computers can be connected by multiple cables.

The next line contains integer k (1 ≤ k ≤ 2·10^4) — the number of experiments. Next k lines contain the experiments’ descriptions. The i-th line contains space-separated integers li, ri (1 ≤ li ≤ ri ≤ m) — the numbers of the cables that Polycarpus disconnects during the i-th experiment.

 

Output

Print k numbers, the i-th number represents the number of connected components of the graph that defines the computer network during the i-th experiment.

 

Examples input

6 5
1 2
5 4
2 3
3 1
3 6
6
1 3
2 5
1 5
5 5
2 4
3 3

 

Examples output

4
5
6
3
4
2

 

题意

给定一张无向图,询问去除索引为 [l,r] [ l , r ] 之间的边以后的联通块个数。

 

思路

去除索引为 [l,r] [ l , r ] 的边以后便只剩余 [1,l1][r+1,m] [ 1 , l − 1 ] ∪ [ r + 1 , m ] 这部分,于是我们用并查集求其前缀和后缀。

每一次的询问只需要将这两部分的边合并,然后便可以得出联通块的个数。

 

AC 代码

#include<bits/stdc++.h>
#define IO ios::sync_with_stdio(false);\
    cin.tie(0);\
    cout.tie(0);
using namespace std;
const int maxn = 510;
const int maxm = 1e4+10;

struct node
{
    int fa[maxn],Bcnt;
    int find_set(int x)
    {
        if(fa[x]!=x)
            fa[x] = find_set(fa[x]);
        return fa[x];
    }
    void union_set(int x,int y)
    {
        x = find_set(x);
        y = find_set(y);
        if(x==y)
            return;
        fa[y] = x;
        ++Bcnt;
    }
    node()
    {
        for(int i=1; i<maxn; i++)
            fa[i] = i;
    }
} L[maxm],R[maxm];

int n,m,q;
int x[maxm],y[maxm];

int main()
{
    IO;
    cin>>n>>m;
    for(int i=1; i<=m; i++)
        cin>>x[i]>>y[i];
    for(int i=1; i<=m; i++)
    {
        L[i] = L[i-1];
        L[i].union_set(x[i],y[i]);
    }
    for(int i=m; i>=1; i--)
    {
        R[i] = R[i+1];
        R[i].union_set(x[i],y[i]);
    }
    cin>>q;
    while(q--)
    {
        int u,v;
        cin>>u>>v;
        node ans = L[u-1];
        for(int i=1; i<=n; i++)
            ans.union_set(ans.find_set(i),R[v+1].find_set(i));
        cout<<n-ans.Bcnt<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值