HDU3336 Count the string

题目链接:HDU3336

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7642    Accepted Submission(s): 3553


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6
 

题意:给出一个字符串s,对于s[1....i]的子串(i从1到最大)一共在s中出现了几次,可以重叠。

题目分析:KMP+DP,首先求出s的next数组,这里next数组应该只能使用未优化的标准求法,因为这里nexts数组储存的是最长的公共前缀与后缀,我们设一个数组dp,dp[i]代表以i结尾的字符串与前缀相同的子串的个数,比如题目中abab对应的dp数组应为1122,其中aba包含a和aba,abab包含abab和ab。具体递推公式为dp[i]=dp[nexts[i]]+1,然后这题的答案就是把dp数组中的所有数加起来了。

//
//  main.cpp
//  HDU3336(1)
//
//  Created by teddywang on 16/5/4.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int N,n,nexts[200010],sum,dp[200010];
char s[200010];

void getnext()
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        {
            nexts[++i]=++j;
            dp[i]=dp[nexts[i]]+1;
        }
        else j=nexts[j];
    }
}

int main()
{
    cin>>N;
    while(N--)
    {
        cin>>n;
        scanf("%s",s);
        getnext();
        sum=0;
        for(int i=1;i<=n;i++)
        {
            sum+=dp[i];
            sum%=10007;
        }
        printf("%d\n",sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值