POJ2828 Buy Tickets

20 篇文章 0 订阅

题目链接:POJ2828

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 17731 Accepted: 8787

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



题意:n个人排队,每个人都喜欢插队,下面是n个人的要插入的位置和这个人的价值,最后输出这n个人的排队顺序。要求每组一行且一个数后面跟一个空格。

题目分析:单点更新的线段树,现考虑n个人的时候把数据逆着插入,因为可以肯定最后一个插队的一定落在自己想要的位置上。建立这几个数组,sum[i]代表以i为根的线段树有几个空的节点,pos代表队列中的位置。v代表价值,ans储存的也是线段树,不过只有在l==r的叶子节点时才有值,值为在那个位置上的人的价值,具体算法如下:

当pos<=sum[rt<<1]时说明pos位置在rt为根的线段的左边,所以访问左儿子,否则访问右儿子。注意当访问右儿子时要对应的将pos值减去sum[rt<<1],意思是整个线段的第pos个空位。

//
//  main.cpp
//  POJ2828
//
//  Created by teddywang on 16/5/12.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 200010
int sum[maxn<<2],v[maxn],pos[maxn],ans[maxn<<2];

void push_up(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void update(int pos,int v,int l,int r,int rt)
{
    if(l==r)
    {
        ans[rt]=v;sum[rt]--;
        return ;
    }
    int m=(l+r)>>1;
    if(pos<=sum[rt<<1]) update(pos,v,lson);
    else update(pos-sum[rt<<1],v,rson);
    push_up(rt);
}

void build(int l,int r,int rt)
{
    sum[rt]=r-l+1;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}

void print(int l,int r,int rt)
{
    if(l==r)
    {
        printf("%d ",ans[rt]);
        return ;
    }
    int m=(l+r)>>1;
    print(lson);
    print(rson);
}

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&pos[i],&v[i]);
        build(1,n,1);
        for(int i=n-1;i>=0;i--)
            update(pos[i]+1,v[i],1,n,1);
        print(1,n,1);
        cout<<endl;
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值