HDU1698 Just a Hook

20 篇文章 0 订阅

题目链接:HDU1698

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26185    Accepted Submission(s): 13092


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

Sample Input
  
  
1 10 2 1 5 2 5 9 3
 

Sample Output
  
  
Case 1: The total value of the hook is 24.
 


题意:没玩过dota,不过图里那个胖子貌似是憎恶,大概是一个线段,初始权值为1,每次更新都改变给定的一段权值,问最后这个线段的权值是多少。

题目分析:第一次写线段树的成段更新,本来准备自己写的,然后写来写去又写回了单点更新果断TLE。后来查了下资料大概明白了,其它的小的疑惑的地方慢慢刷题解决吧。

主要是运用lazy数组记录本来需要向下更新但是没有更新的节点,0代表没有改变,其余代表改变的大小。向下更新当遇到lazy不为0的情况代表这个点的向下更新必须要处理,这样可以省略许多运算步骤。详细的算法思想等写完成段更新的题目后再补上。

//
//  main.cpp
//  HDU1698
//
//  Created by teddywang on 16/5/18.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define N 100010

int sum[N<<2],lazy[N<<2];
int kase,n,tims;

void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void pushdown(int rt,int m)
{
    if(lazy[rt])
    {
        lazy[rt<<1]=lazy[rt<<1|1]=lazy[rt];
        sum[rt<<1]=lazy[rt]*(m-(m>>1));
        sum[rt<<1|1]=lazy[rt]*(m>>1);
        lazy[rt]=0;
    }
}

void build(int l,int r,int rt)
{
    lazy[rt]=0;
    sum[rt]=r-l+1;
    if(l==r) return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}

void update(int z,int l1,int r1,int l,int r,int rt)
{
    if(l1<=l&&r<=r1)
    {
        sum[rt]=(r-l+1)*z;
        lazy[rt]=z;
        return;
    }
    pushdown(rt,r-l+1);
    int m=(l+r)>>1;
    if(l1<=m) update(z,l1,r1,lson);
    if(r1>m) update(z,l1,r1,rson);
    pushup(rt);
}

int main()
{
    scanf("%d",&kase);
    for(int i=1;i<=kase;i++)
    {
        scanf("%d",&n);
        build(1,n,1);
        scanf("%d",&tims);
        while(tims--)
        {
            
            int l,r,z;
            scanf("%d%d%d",&l,&r,&z);
            update(z,l,r,1,n,1);
        }
        printf("Case %d: The total value of the hook is %d.\n",i,sum[1]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值