HDU5745 La Vie en rose

题目链接:HDU5745

La Vie en rose

Time Limit: 14000/7000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 871    Accepted Submission(s): 467


Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string  p=p1p2...pm . So, he wants to generate as many as possible pattern strings from  p  using the following method:

1. select some indices  i1,i2,...,ik  such that  1i1<i2<...<ik<|p|  and  |ijij+1|>1  for all  1j<k .
2. swap  pij  and  pij+1  for all  1jk .

Now, for a given a string  s=s1s2...sn , Professor Zhang wants to find all occurrences of all the generated patterns in  s .
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  m   (1n105,1mmin{5000,n})  -- the length of  s  and  p .

The second line contains the string  s  and the third line contains the string  p . Both the strings consist of only lowercase English letters.
 

Output
For each test case, output a binary string of length  n . The  i -th character is "1" if and only if the substring  sisi+1...si+m1  is one of the generated patterns.
 

Sample Input
      
      
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

Sample Output
      
      
1010 1110 100100100
 

Author
zimpha
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5746  5743  5741  5740  5739 
 

题意:比赛的时候看了2个小时没有理解题目意思。下来对着题解的代码凝视了好久终于大概明白了一些。题的意思是进行多模式串的匹配,在给定的模式串p上给每个位置标号1到lp,然后从1到p-1随意找出一组标号,要求标号要不能相连,就是隔着取,然后把这些标号对应的位置与相邻的右一个交换位置,这样就组成了一堆新的模式串。要求求出所有匹配的模式串的起始位置。

题目分析:按照答案的正解是dp加位操作,这个我过一阵再写,网上大多数做法是暴力搞,复杂度O(mn),4500ms勉强过。仔细想下10w*5k*T竟然不到5s就跑过了,数据也是够弱的。
//
//  main.cpp
//  La Vie en rose
//
//  Created by teddywang on 2016/7/21.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAX 500010
#define MIN 11000
int T,ls,lp;
int poss,posp;
int ans[100010];
char s[100010],p[5005];
int main()
{
    cin>>T;
    while(T--)
    {
        memset(ans,0,sizeof(ans));
        scanf("%d%d",&ls,&lp);
        scanf("%s",s);
        scanf("%s",p);
        poss=posp=0;
        while(poss<ls&&posp<lp)
        {
            if(s[poss]==p[posp])
            {
                if(posp==lp-1)
                {
                    ans[poss-posp]=1;
                    poss=poss-posp+1;
                    posp=0;
                }
                else
                {
                    poss++;
                    posp++;
                }
            }
            else if(s[poss]==p[posp+1]&&s[poss+1]==p[posp])
            {
                if(posp==lp-2)
                {
                    ans[poss-posp]=1;
                    poss=poss-posp+1;
                    posp=0;
                }
                else
                {
                    poss+=2;
                    posp+=2;
                }
            }
            else
            {
                poss=poss-posp+1;
                posp=0;
            }
        }
        for(int i=0;i<ls;i++)
            printf("%d",ans[i]);
        printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值