POJ2282 The Counting Problem:

7 篇文章 0 订阅
1 篇文章 0 订阅

题目链接:POJ2282

The Counting Problem
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 4097 Accepted: 2160

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032 

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc. 

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247
题意:给出2个数a和b,求之间所有数中包含0到9的个数总和。
题目分析:数位dp,首先预处理出i位数中含有j的个数,之后求1到a中j的个数和1到b中j的个数,再一减就行了。
注意要消除高位0的影响,求0的个数时需要对最高位进行特判。
//
//  main.cpp
//  POJ2282
//
//  Created by teddywang on 2016/10/5.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int num[10];
int dp[10][10];//dp[i][j]为i位数含数字j的个数
int a,b;

void init()
{
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=9;i++)
    {
        for(int j=0;j<=9;j++)
            dp[i][j]=dp[i-1][j]*10+(int)pow(10.0,i-1);
    }
}

int solve(int n,int m)
{
    int p[10]={0},len=1,ans=0,cnt=0;
    while(n)
    {
        p[len++]=n%10;
        n/=10;
    }
    len--;
    for(int i=len;i>=1;i--)
    {
        if(m==0&&i==len)//特判取0的情况
        {
            ans+=dp[i-1][m]*(p[i]-1);//不算前导0
            int buf=pow(10.0,i-1)-1;
            ans+=solve(buf,0);//加上高位为0时的个数
        }
        else ans+=p[i]*dp[i-1][m];//p[i]个i-1位数相加
        ans+=cnt*pow(10.0,i-1)*p[i];//把高位含m的情况算进去
        if(m||(m==0&&i<len))
        {
            if(p[i]>m)
                ans+=pow(10.0,i-1);
            if(p[i]==m)
                cnt++;
        }
    }
    return ans+cnt;//加cnt是这个数本体含m的个数
}

int main()
{
    int a,b;
    init();
    while(cin>>a>>b)
    {
        if(a==0&&b==0) break;
        if(a<b) swap(a,b);
        cout<<solve(a,0)-solve(b-1,0);
        for(int i=1;i<=9;i++)
            cout<<" "<<(solve(a,i)-solve(b-1,i));
        cout<<endl;
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值