POJ 2104 K-th Number 静态第K大模板

题目链接:POJ 2104

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 59422 Accepted: 20698
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5. 

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k). 

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment. 

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

题意:给出一个序列,求L,R中第K大数。
题目分析:静态第k大的主席树模板,主席树本质上是可持久化的线段树的结构,首先把原序列排序后按每棵线段树保存前缀[1,i]来构建一棵空的线段树,之后按原序列挨个插入,每插入一个数都相当于新建一棵线段树。在第i棵线段树的每个节点保存原序列[1,i]出现在节点代表区间的个数。每棵线段树的结构是一样的,这样在查询L,R的第k大时只需2棵线段树R,L-1相减,代表同一区间的2节点相减代表原序列[L,R]在出现在当前区间有多少个元素,之后logn查询即可。
我理解的主席树就是支持加减的一堆结构完全相同的线段树,同时每次插入一个点构成的新的一棵线段树和前面的那棵只有一条路径不同,所以把每次只添加这一条路径就可以大大减少区间消耗。
//
//  main.cpp
//  POJ 2104 K-th Number
//
//  Created by teddywang on 2017/09/07.
//  Copyright © 2017年 teddywang. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
struct Node{
    int a,b,rs,ls,sum;
}tr[2000010];
int a[100010];
int rt[100010],pos,cnt;
struct node{
    int id;
    int num;
    friend bool operator < (node a,node b)
    {
        return a.num<b.num;
    }
}b[100010];
int ranks[100010];
void Build(int &node,int l,int r)
{
    node=++cnt;
    tr[node].a=l;
    tr[node].b=r;
    if(l==r)return;
    int mid=(l+r)>>1;
    Build(tr[node].ls,l,mid);
    Build(tr[node].rs,mid+1,r);
}

void Insert(int pre,int &node)
{
    node=++cnt;
    tr[node].ls=tr[pre].ls;
    tr[node].rs=tr[pre].rs;
    tr[node].a=tr[pre].a;
    tr[node].b=tr[pre].b;
    tr[node].sum=tr[pre].sum+1;
    if(tr[node].a==tr[node].b)return;
    int mid=(tr[node].a+tr[node].b)>>1;
    if(mid>=pos)Insert(tr[pre].ls,tr[node].ls);
    else Insert(tr[pre].rs,tr[node].rs);
}
int Query(int pre,int node,int k)
{
    if(tr[node].ls==tr[node].rs)return b[tr[node].a].num;
    int cmp=tr[tr[node].ls].sum-tr[tr[pre].ls].sum;
    if(cmp>=k)return Query(tr[pre].ls,tr[node].ls,k);
    else return Query(tr[pre].rs,tr[node].rs,k-cmp);
}
int main()
{
    int n,q;
    scanf("%d%d",&n,&q);
    for(int i=1;i<=n;b[i].num=a[i],i++)
    {
        scanf("%d",&a[i]);
        b[i].id=i;
    }
    sort(b+1,b+n+1);
    for(int i=1;i<=n;i++)
    {
        ranks[b[i].id]=i;
    }
    Build(rt[0],1,n);
    for(int i=1;i<=n;i++)
    {
        pos=ranks[i];
        Insert(rt[i-1],rt[i]);
        
    }
    int l,r,k;
    for(int i=1;i<=q;i++)
    {
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",Query(rt[l-1],rt[r],k));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值