hdoj-2017 字符串统计【字符串】

15 篇文章 0 订阅

题目详见http://acm.hdu.edu.cn/showproblem.php?pid=2017

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9
 
scanf(),gets()读取字符串的区别:
	scanf()遇' '和"\n"(空格和回车)停止
	gets()遇"\n"停止
 
code 1:
 
#include<stdio.h>
#include<string.h>
int main()
{
	char s[100];
	int i,n,cnt;
	scanf("%d",&n);
	while(n--){
		scanf("%s",&s);
		cnt=0;
		for(i=0;i<strlen(s);i++)
		{
			if(s[i]>='0'&&s[i]<='9')//或 if(s[i]>=48&&s[i]<=57)ASCII码值 
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}
code 2: 
#include<stdio.h>
#include<string.h>
int main()
{
	char s[100];
	int i,n,cnt;
	scanf("%d",&n);
	getchar();
	while(n--){
		gets(s);
		cnt=0;
		for(i=0;i<strlen(s);i++)
		{
			if(s[i]>='0'&&s[i]<='9')//或 if(s[i]>=48&&s[i]<=57)ASCII码值 
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}
 
数字后 按下回车 下面紧跟一个0   所以在数字输入后面插入getchar() 把0丢弃
code3是我偶然写出来的代码  本人菜鸟一枚 至于为什么那么使用尴尬 我也不理解  如果哪位大神知道 还望赐教
 code 3:
#include<stdio.h>
#include<string.h>
int main()
{
	char s[100];
	int i,n,cnt;
	scanf("%d\n",&n);//%d后+\n,下面就可以使用gets(s) 
	while(n--){
		gets(s);
		cnt=0;
		for(i=0;i<strlen(s);i++)
		{
			if(s[i]>='0'&&s[i]<='9')//或 if(s[i]>=48&&s[i]<=57)ASCII码值 
			cnt++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值