算法提高 不同单词个数统计

问题描述
  编写一个程序,输入一个句子,然后统计出这个句子当中不同的单词个数。例如:对于句子“one little two little three little boys”,总共有5个不同的单词:one, little, two, three, boys。
  说明:(1)由于句子当中包含有空格,所以应该用gets函数来输入这个句子;(2)输入的句子当中只包含英文字符和空格,单词之间用一个空格隔开;(3)不用考虑单词的大小写,假设输入的都是小写字符;(4)句子长度不超过100个字符。
  输入格式:输入只有一行,即一个英文句子。
  输出格式:输出只有一行,是一个整数,表示句子中不同单词的个数。
输入输出样例
样例输入
one little two little three little boys
样例输出
5

#include<stdio.h>
#include<string.h>
int n,count;						//统计单词的个数 
char arr[1050];
char temp[1000][1000];
void different()
{
	int i,j;
/*	for(i=0;i<=n;i++)
		puts(temp[i]);
*/	for(i=0;i<=n;i++)
	{
		for(j=i+1;j<=n;j++)
		{
			if(strcmp(temp[i],temp[j])==0)
			{
				strcpy(temp[j],"");
			}
		}
//		puts(temp[i]);
		if(strcmp(temp[i],"")!=0)
			count++;
	}
	printf("%d\n",count);
}
void word()
{
	char *p=arr;
	int j;
	while(*p)
	{
		if(*p==' ' && *(p+1)!=' ')
		{
			temp[n][j]='\0';
			j=0;
			n++;
		}
		if(*p!=' ')
		{
			temp[n][j++]=*p;
		}
		p++;
	}
}
int main()
{
	while(gets(arr))
	{
		n=0;
		count=0;
		word();
		different();
	} 
	return 0;
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值