最大公约数

最大公约数

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述
编写程序,输入两个正整数x和y,求它们的最大公约数。
输入
有多组测试数据,以EOF结束。
每组测试数据有2个整数x、y。
输出
每组数据输出一行。
样例输入
8,6
样例输出
2

import java.util.Scanner;

public class Main {

	public static void fun(int numone, int numtwo) {
		int temp = numone % numtwo;
		while (temp != 0) {
			numone = numtwo;
			numtwo = temp;
			temp = numone % numtwo;
		}
		System.out.println(numtwo);
	}

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			String str = scanner.nextLine();
			String arr[] = str.split(",");
			int numone = Integer.parseInt(arr[0]);
			int numtwo = Integer.parseInt(arr[1]);
			if (numone > numtwo) {
				fun(numone, numtwo);
			} else {
				fun(numtwo, numone);
			}
		}
	}

}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值