郁闷的c小加(一)

郁闷的C小加(一)

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述

我们熟悉的表达式如a+ba+b*(c+d)等都属于中缀表达式。中缀表达式就是(对于双目运算符来说)操作符在两个操作数中间:num1 operand num2。同理,后缀表达式就是操作符在两个操作数之后:num1 num2 operandACM队的“C小加”正在郁闷怎样把一个中缀表达式转换为后缀表达式,现在请你设计一个程序,帮助C小加把中缀表达式转换成后缀表达式。为简化问题,操作数均为个位数,操作符只有+-*/ 和小括号。

输入
第一行输入T,表示有T组测试数据(T<10)。
每组测试数据只有一行,是一个长度不超过1000的字符串,表示这个表达式。这个表达式里只包含+-*/与小括号这几种符号。其中小括号可以嵌套使用。数据保证输入的操作数中不会出现负数。并且输入数据不会出现不匹配现象。
输出
每组输出都单独成行,输出转换的后缀表达式。
样例输入
21+2(1+2)*3+4*5
样例输出
12+12+3*45*+

import java.util.Scanner;
import java.util.Stack;

public class Main {

	public static void main(String[] args) {
		Scanner scanner = new Scanner(System.in);
		int times = scanner.nextInt();
		String cc = scanner.nextLine();
		while (times-- != 0) {
			String str = scanner.nextLine();
			Stack<Character> stack = new Stack<Character>();
			for (int i = 0; i < str.length(); i++) {
				char top = str.charAt(i);
				if (top >= '0' && top <= '9') {
					System.out.print(top);
				} else {
					if (top == '+' || top == '-') {
						if (stack.isEmpty()) {
							stack.push(top);
						} else {
							if (stack.peek() == '(') {
								stack.push(top);
							} else {
								while (!stack.isEmpty() && stack.peek() != '(') {
									System.out.print(stack.pop());
								}
								stack.push(top);
							}
						}
					} else if (top == '*' || top == '/') {
						if (stack.isEmpty()) {
							stack.push(top);
						} else {
							if (stack.peek() == '(') {
								stack.push(top);
							} else {
								if (stack.peek() == '+' || stack.peek() == '-'
										|| stack.peek() == '(') {
									stack.push(top);
								} else if (stack.peek() == '*'
										|| stack.peek() == '/') {
									System.out.print(stack.pop());
									stack.push(top);
								}
							}
						}
					} else if (top == '(') {
						stack.push(top);
					} else if (top == ')') {
						char temp = stack.pop();
						while (temp != '(') {
							System.out.print(temp);
							temp = stack.pop();
						}
					}
				}
			}
			while (!stack.isEmpty()) {
				System.out.print(stack.pop());
			}
			System.out.println();
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值