SWUST OJ 536: The Josephus Problem

题目描述

The problem is named after Flavius Josephus, a Jewish historian who participated in and chronicled the Jewish revolt of 66-70C.E. against the Romans. Josephus, as a general, managed to hold the fortress of Jotapata for 47days, but after the fall of the city he took refuge with 40 diehards in a nearby cave. There the rebels voted to perish rather than surrender. Josephus proposed that each man in turn should dispatch his neighbor, the order to be determined by casting lots. Josephus contrived to draw the last lot, and as one of the two surviving men in the cave, he prevailed upon his intended victim to surrender to the Romans. Your task:computint the position of the survivor when there are initially n people.

输入

a Positive Integer n is initially people. n< = 50000

输出

the position of the survivor

样例输入

6

样例输出

6

参考程序

方法一:

#include <iostream>
using namespace std;
int Func(int, int);
int main() {
    int n(0), k(2);
    cin >> n;
    cout << Func(n, k) + 1 << endl;
    return 0;
}
int Func(int n, int k) {
    if (n == 1)
        return 0;
    else
        return (Func(n - 1, k) + k) % n;
}

方法二:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n;
    int f = 0;
    cin >> n;
   	for(int i=1; i<=n; i++){
   		f = (f+2)%i; 
	   }
	cout << f+1<<endl;
    return 0;
}

注意

该程序仅供学习参考!

  • 0
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

无奈清风吹过

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值