SWUST OJ 1139: Coin-row problem

题目描述

There is a row of n coins whose values are some positive integers c₁, c₂,…,cn, not necessarily distinct. The goal is to pick up the maximum amount of money subject to the constraint that no two coins adjacent in the initial row can be picked up.

输入

Two lines, the first line is n (0< n <=10000), and the second line is value of coin(0< value <= 2^32).

输出

the maximum amount of money.

样例输入

6
5 1 2 10 6 2

样例输出

17

参考程序

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int Max(int a,int b)
    {
        return a>b?a:b;
    }
int main()
{
    int n;
    cin>>n;
    int a[10001]={0},v[10001]={0};
    for(int i=1;i<=n;i++)
    {
        cin>>a[i];
    }
 
 
    v[1]=a[1];
    for(int i=2;i<=n;i++)
    {
        v[i]=Max(v[i-1],v[i-2]+a[i]);
    }
    cout<<v[n]<<endl;
    return 0;
}


注意

该程序仅供学习参考!

  • 0
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

无奈清风吹过

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值