PAT甲级(Advanced Level)----1001

1001 A+B Format (20point(s))

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ≤ a , b ≤ 1 0 6 -10^{6} \leq a, b \leq 10^{6} 106a,b106
​ The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

意思就是将a 和 b 相加的结果以逗号进行分割。

#include <iostream>
#include <stack>
using namespace std;

int main()
{
	stack<int> s;
	int a,b,sum,count=0,flag=1;  //flag为正负的标志
	cin>>a>>b;
	sum = a+b;
	if(sum<0)                    //统一化为正数处理,只在输出时分正负
	{
		flag = 0;
		sum=-sum;
	}
	
	if(sum == 0)				//这个是测试样例之一,要考虑到
    {
        cout<<0;
        return 0;
    }
    
	while(sum!=0)               
	{
		s.push(sum%10);			//将最后一位的数字入栈
		sum/=10;				
		count++;				
        if(count == 3)			//每push3个数,push一个 -1,因为-1不会是对正数取模运算后的结果
        {
            s.push(-1);			
            count = 0;          //重置为0
        }
	}

	if(flag==1) ;
	else cout<<'-';

    if(s.top() == -1) s.pop();	//结果正好位6位数的时候,需要pop掉栈顶的-1,在开头
	while(!s.empty())
	{
		if(s.top()!= -1)
            cout<<s.top();
		else
            cout<<",";         //为-1时输出 ","
        s.pop();
	}
	return 0;
}

下面这段是柳神的做法:
她的blog链接:https://www.liuchuo.net/archives/1888

#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++) {
        cout << s[i];
        if (s[i] == '-') continue;
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值