10-排序5 PAT Judge

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (), the total number of users, K (), the total number of problems, and M (), the total number of submissions. It is then assumed that the user id's are 5-digit numbers from 00001 to N, and the problem id's are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either  if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id's. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

#include<stdio.h>
#include<stdlib.h>

typedef struct Node {
	//int stn;	//学生号
	int grade[6];	//成绩
	int pref;		//满分题目数
	int num;		//总分
}Nodes;


int PanDuan(int *a, Nodes *N, int center, int right) {		//right》center返回1
	if (N[a[right]].num > N[a[center]].num || N[a[right]].num == N[a[center]].num&&N[a[right]].pref > N[a[center]].pref || N[a[right]].num == N[a[center]].num&&N[a[right]].pref == N[a[center]].pref&&right < center) {
		return 1;
	}
	return 0;
}


//归并排序

void sort1(int *n, int left, int right, int *b, Nodes *N) {
	int L = left;
	int C = (left + right) / 2;
	int K = left;
	int R = C + 1;
	while (L!=C+1&&R!=right+1)
	{
		if (PanDuan(n, N, L, R)) {	//R>L
			b[K++] = n[R++];
		}
		else {
			b[K++] = n[L++];
		}
	}
	while (L != C + 1)
	{
		b[K++] = n[L++];
	}
	while (R != right + 1)
	{
		b[K++] = n[R++];
	}
	for (int i = left; i < right+1; i++)
	{
		n[i] = b[i];
	}
}

void apatr(int *n, int left, int right, int *b, Nodes *N) {
	int center = (left + right) / 2;
	if (right > left) {
		apatr(n, left, center, b, N);
		apatr(n, center+1, right, b, N);
		sort1(n, left, right, b, N);
	}
}

void sort(int *n, int left, int right, Nodes *N) {
	int b[10001];
	apatr(n, left, right, b, N);
}


int main()
{
	int b[6] = { 0 };	//各科满分数
	int stns, gs, ps;	//学生数、题目数、提交数
	//stns = 10000, gs = 1, ps = 100000;
	scanf("%d %d %d", &stns, &gs, &ps);
	for (int i = 1; i <= gs; i++)
	{
		scanf("%d", &b[i]);
		//b[i] = 20;
	}
	int snumber, gn, grades;	//学生号,题目号,成绩
	Nodes N[10001];

	for (int i = 1; i <= stns; i++)	//初始化
	{
		for (int j = 1; j <= gs; j++)
		{
			N[i].grade[j] = -2;
		}
		N[i].pref = 0;
		N[i].num = 0;
	}



	for (int i = 1; i <=ps; i++)
	{
		/*snumber = (i*i) % 10000 + 1;
		gn = 1;
		grades = (i*i+2*i+10)%12-1;*/
		scanf("%d %d %d", &snumber, &gn, &grades);
		if (grades>N[snumber].grade[gn]) {
			N[snumber].grade[gn] = grades;
			if (grades == b[gn])N[snumber].pref++;
		}
	}

	for (int i = 1; i <= stns; i++)
	{
		int flag= 0;
		for (int j = 1; j <= gs; j++)
		{
			if (N[i].grade[j]>=0) {
				N[i].num += N[i].grade[j];
				flag = 1;		//有提交通过的题(0也算)
			}
		}
		if (flag == 0)N[i].num = -1;	//-1表示没提交,或编译没通过
	}

	int n[100001];	//记录排序序号
	int kk = 1;
	for (int i = 1; i <=stns; i++)
	{
		if (N[i].num >= 0) {
			n[kk++] = i;
		}
	}
	//select_sort(N, n, 1,kk-1);

	sort(n, 1, kk-1, N);
	int index = 1;
	for (int i = 1; i < kk; i++)
	{
		printf("%d %05d %d",index,n[i],N[n[i]].num);
		if (n[i + 1] >0&&n[i + 1] <=stns&&N[n[i]].num!= N[n[i+1]].num) {
			index = i+1;
		}
		for (int j = 1; j <=gs; j++)
		{
			if (N[n[i]].grade[j] ==-2) {
				printf(" -");
			}
			else if (N[n[i]].grade[j] == -1) {
				printf(" 0");
			}
			else {
				printf(" %d", N[n[i]].grade[j]);
			}
		}
		printf("\n");
	}
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值