PAT甲级 1028 List Sorting(25 分)排序

113 篇文章 9 订阅

1028 List Sorting(25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

思路:直接用sort进行排序。只需注意排序时三种不同的比较方式,可通过flag判别是哪一种。 

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;

struct stu{
	int id,score;
	string name;
};

int flag = -1;

int cmp(stu a,stu b){
	if(flag == 1)
		return a.id < b.id;
	else if(flag == 2)
		return a.name != b.name? a.name < b.name : a.id < b.id;//名字相同时按ID升序排 
	else
		return a.score != b.score? a.score < b.score : a.id < b.id;
}

int main(){
	int n,c;
	cin>>n>>c;
	flag = c;
	vector<stu> record(n);
	for(int i=0;i<n;i++)
	{
		cin>>record[i].id;
		cin>>record[i].name;
		cin>>record[i].score;
	}
	
	sort(record.begin(),record.end(),cmp);
	
	for(int i=0;i<n;i++)
	{
		//因为string不是c语言的内置数据,所以直接printf输出string类型的是办不到的
		printf("%06d %s %d\n",record[i].id,(record[i].name).c_str(),record[i].score);
	}
	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值