PAT甲级 1036 Boys vs Girls(25 分)map,vector,排序

113 篇文章 9 订阅

1036 Boys vs Girls(25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

解析:该题很简单,送分题。方法就是建立一个map,map中的key为gender,value为学生信息,这样方便对男生和女生分别进行存储,也方便直接分别排序。 

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>

using namespace std;

struct node{
	string name,id;
	int grade;
};

int flag = -1;

int cmp(node a,node b){
	if(flag == 0)
		return a.grade > b.grade;
	else
		return a.grade < b.grade;
}

int main(){
	int n;
	cin>>n;
	map<char,vector<node>> mp;
	for(int i=0;i<n;i++){
		string name,id;
		int grade;
		char gender;
		cin>>name>>gender>>id>>grade;
		mp[gender].push_back(node{name,id,grade});
	}
	
	int score1 = -1,score2 = -1;
	if(mp.find('F') == mp.end())
		cout<<"Absent"<<endl;
	else{
		vector<node> vec = mp['F'];
		flag = 0;
		sort(vec.begin(),vec.end(),cmp);
		score1 = vec[0].grade;
		cout<<vec[0].name<<" "<<vec[0].id<<endl;
	}
	
	if(mp.find('M') == mp.end())
		cout<<"Absent"<<endl;
	else{
		vector<node> vec = mp['M'];
		flag = 1;
		sort(vec.begin(),vec.end(),cmp);
		score2 = vec[0].grade;
		cout<<vec[0].name<<" "<<vec[0].id<<endl;
	}
	
	if(score1 == -1 || score2 == -1)
		cout<<"NA"<<endl;
	else
		cout<<score1 - score2<<endl;
	
	return 0;
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值