PAT甲级 1037 Magic Coupon(25 分)贪心算法

113 篇文章 9 订阅

1037 Magic Coupon(25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题目大意:给出两个数字序列,从这两个序列中分别选取相同数量的元素进行一对一相乘,问能得到的乘积之和最大为多少~~~
分析:把这两个序列都从的正负数分开存储,并将正数按降序排列,负数按升序排列。然后将正数与负数配对求和即可~~~ 

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int cmp(int a,int b){
	return a < b;
}

int cmp1(int a,int b){
	return a > b;
}

int main(){
	int n,m,a;
	cin>>n;
	vector<int> coupons_pos,coupons_nega;
	for(int i=0;i<n;i++)
	{
		cin>>a;
		if(a > 0)
			coupons_pos.push_back(a);
		else
			coupons_nega.push_back(a);
	}
	
	cin>>m;
	vector<int> product_pos,product_nega;
	for(int i=0;i<m;i++)
	{
		cin>>a;
		if(a > 0)
			product_pos.push_back(a);
		else
			product_nega.push_back(a);
	}
	
	sort(product_pos.begin(),product_pos.end(),cmp1);
	sort(coupons_pos.begin(),coupons_pos.end(),cmp1);
	
	sort(product_nega.begin(),product_nega.end(),cmp);
	sort(coupons_nega.begin(),coupons_nega.end(),cmp);
	
	int res = 0;
	for(int i=0;i<product_pos.size() && i < coupons_pos.size();i++)
		res += (product_pos[i]*coupons_pos[i]);	
	
	for(int i=0;i<product_nega.size() && i < coupons_nega.size();i++)
		res += (product_nega[i]*coupons_nega[i]);
	cout<<res<<endl;
		
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值