PAT甲级 1038 Recover the Smallest Number(30 分)贪心算法,cmp和string的应用

113 篇文章 9 订阅

1038 Recover the Smallest Number(30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

 题目大意:给一些字符串,求它们拼接起来构成最小数字的方式
分析:贪心算法。让我们一起来见证cmp函数的强大之处!!~~~~不是按照字典序排列就可以的,必须保证两个字符串构成的数字是最小的才行,所以cmp函数写成return a + b < b + a;的形式,保证它排列按照能够组成的最小数字的形式排列。
因为字符串可能前面有0,这些要移除掉(用s.erase(s.begin())就可以了~~嗯~~string如此神奇~~~)。输出拼接后的字符串即可。
注意:如果移出了0之后发现s.length() == 0了,说明这个数是0,那么要特别地输出这个0,否则会什么都不输出。

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int cmp(string a,string b){
	return a+b < b+a;
}

int main(){
	int n;
	cin>>n;
	string str;
	vector<string> vec(n);
	for(int i=0;i<n;i++){
		cin>>str;
		vec[i] = str;
	}
	sort(vec.begin(),vec.end(),cmp);
	string res;
	for(int i=0;i<n;i++)
		res += vec[i];
	
	while(res.length() != 0 && res[0] == '0')
		res.erase(res.begin());//注意,string与容器该操作方法一致,vector也是vec.erase 

	if(res.length() == 0)
		cout<<0;
	else
		cout<<res;
	
	return 0;
} 

写法二:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int cmp(string a,string b){
	return a+b < b+a;
}

int main(){
	int n;
	cin>>n;
	string str;
	vector<string> vec(n);
	for(int i=0;i<n;i++){
		cin>>str;
		vec[i] = str;
	}
	sort(vec.begin(),vec.end(),cmp);
	string res;
	for(int i=0;i<n;i++)
		res += vec[i];
	
	int len = res.length(),flag = 0;
	for(int i=0;i<len;i++)
		if(res[i] != '0'){
			flag = 1;
			break;
		}
	if(flag == 0){//若全部字符都是0 
		cout<<'0';
		return 0;
	}
			
	for(int i=0;i<len;i++)
		if(res[i] == '0')
			continue;
		else{
			for(int j=i;j<len;j++){
				cout<<res[j];	
			}
			return 0;
		}		
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值