PAT甲级 1046 Shortest Distance(20 分)模拟,简便运算

113 篇文章 9 订阅

1046 Shortest Distance(20 分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​, where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

PS:若采用每次都顺序与逆序求一次最短距离的方法,会导致超时,此法不可取。只能得17分。

分析:简单模拟。所有结点连起来会形成一个环形,dsp[i]存储第1个结点到第i个结点的下一个结点的距离,dsp[n]保存整个路径一圈的总和值。求得结果就是dis[end – 1] – dis[now – 1]和 sum – dis[end– 1] +dis[now – 1]中较小的那一个~~
注意:可能now和end的顺序颠倒了,这时候要把now和end的值交换~ 

#include <stdio.h>
#include <vector>
using namespace std;

int main( )
{
	int n,m,dis;
	scanf("%d",&n);
	vector<int> dsp(n+1,0);
	for(int i=1;i<=n;i++){
		scanf("%d",&dsp[i]);
		dsp[i] = dsp[i-1] + dsp[i];
	}
	
	scanf("%d",&m);
	int now,end,res;
	for(int i=0;i<m;i++){
		scanf("%d %d",&now,&end);
		if(now > end){
			swap(now,end);//直接调用swap交换两个值 
		}
		res = min(dsp[end-1] - dsp[now-1],(dsp[n]-dsp[end-1]) + dsp[now-1]);
		printf("%d\n",res);
	}
		
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值