1068 Find More Coins (30 分)

113 篇文章 9 订阅
12 篇文章 0 订阅

1068 Find More Coins (30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V​2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

题目大意:用n个硬币买价值为m的东西,输出使用方案,使得正好几个硬币加起来价值为m。从小到大排列,输出最小的那个排列方案

分析: 直接用dfs做即可,操作简单。有一个点是所有硬币的价值总和都达不到m,直接判断.

#include <bits/stdc++.h>
using namespace std;

int n,m,sum = 0;
vector<int> arr;
vector<int> vec,res;

void dfs(int index,int sum,int &flag){	
	if(sum > m || flag == 1)//剪枝操作
		return;
	if(sum == m && flag == 0){
		res = vec;
		flag = 1;
		return ;
	}	
		
	for(int i=index;i<=n;i++){
		vec.push_back(arr[i]);
		dfs(i+1,sum+arr[i],flag);
		vec.pop_back();	
	}
}

int main() {
  	scanf("%d%d",&n,&m);
  	arr.resize(n+1);
  	int total = 0;
  	for(int i=1;i<=n;i++){
  		scanf("%d",&arr[i]);
  		total += arr[i];
  	}
  	if(total < m)
  	{
  		printf("No Solution");
  		return 0;
  	}
  	sort(arr.begin(),arr.end());
  
  	int flag = 0;
  	dfs(1,0,flag);
  	if(flag){
  		for(int i=0;i<res.size();i++)
  			printf("%d%s",res[i],i==res.size()-1?"":" ");
  	}else
  		printf("No Solution");
  
    return 0;
}

放一下dfs 的 push与pop过程,帮助理解。 

 

这里我换了一个写法,有一个点没AC,只拿到25分,暂时先放在这。

找到原因: 这种dfs写法第一个点永远不会被pop出去!!!!所以是错的

#include <bits/stdc++.h>
using namespace std;

int n,m,sum = 0;
vector<int> arr;
vector<int> vec,res;

void dfs(int index,int sum,int &flag){
	if(sum > m || flag == 1)//剪枝操作
		return;
	if(sum == m && flag == 0){
		res = vec;
		flag = 1;
		return ;
	}
		
	for(int i=index+1;i<=n;i++){
		vec.push_back(arr[i]);	
		dfs(i,sum + arr[i],flag);
		vec.pop_back();	
	}
}

int main() {
  	scanf("%d%d",&n,&m);
  	arr.resize(n);
  	int total = 0;
  	for(int i=0;i<n;i++){
  		scanf("%d",&arr[i]);
  		total += arr[i];
  	}
  	if(total < m)
  	{
  		printf("No Solution");
  		return 0;
  	}
  	sort(arr.begin(),arr.end());//默认从小到大排序 
  
  	int flag = 0;
  	vec.push_back(arr[0]);//初始时给vec和sum赋第一个点的值 
  	dfs(0,arr[0],flag);
  	if(flag){
  		for(int i=0;i<res.size();i++)
  			printf("%d%s",res[i],i==res.size()-1?"":" ");
  	}else
  		printf("No Solution");
  
    return 0;
}

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值