PAT 1081 Rational Sum (20 分)分数的四则运算

113 篇文章 9 订阅

1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

题目大意:给N个有理数(以分子/分母的形式给出),计算这N个数的总和,最后总和要以(整数 分子/分母)的形式给出~

分析:先根据分数加法的公式累加,后分离出整数部分和分数部分
分子和分母都在长整型内,所以不能用int存储,否则有一个测试点不通过
一开始一直是浮点错误,按理来说应该是出现了/0或者%0的情况,后来注意到应该在累加的时候考虑是否会超出long long的范围,所以在累加每一步之前进行分子分母的约分处理

应该还要考虑整数和小数部分都为0时候输出0的情况,但是测试用例中不涉及,所以如果没有最后两句也是可以AC的

注意: 5对20求余,结果是5.

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

int fun(long long a,long long b){
	while(a%b != 0){
		int temp = a % b;
		a = b;
		b = temp;
	}
	return b;
}

int main(){

	long long n,a,b,suma = 0,sumb = 1,gcdvalue;
	scanf("%lld",&n);
	for(int i = 0;i<n;i++)
	{
		scanf("%lld/%lld",&a,&b);
		gcdvalue = fun(a,b);
		a = a / gcdvalue;
		b = b / gcdvalue;
		suma = a*sumb + suma*b;
		sumb = sumb * b;
		gcdvalue = fun(suma,sumb);
		suma /= gcdvalue;
		sumb /= gcdvalue;
	}

	int flag = 0;
	if(suma/sumb != 0){
		cout<<suma/sumb;
		flag = 1;
	}

	if(suma%sumb != 0){
		if(flag == 1)
			cout<<" ";
		cout<<suma%sumb<<"/"<<sumb;
	}

	if(suma/sumb == 0 && suma%sumb == 0)
		cout<<0;

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值