PATj甲级 1087 All Roads Lead to Rome (30 分)dijkstra + dfs

113 篇文章 9 订阅
12 篇文章 0 订阅

1087 All Roads Lead to Rome (30 分)

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2≤N≤200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N−1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness -- it is guaranteed by the judge that such a solution exists and is unique.

Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

Sample Output:

3 3 195 97
HZH->PRS->ROM

题目大意:有N个城市,M条无向边,从某个给定的起始城市出发,前往名为ROM的城市。每个城市(除了起始城市)都有一个点权(称为幸福值),和边权(每条边所需的花费)。求从起点到ROM所需要的最少花费,并输出其路径。如果路径有多条,给出幸福值最大的那条。如果仍然不唯一,选择路径上的城市平均幸福值最大的那条路径

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;

const int N = 202,inf = 99999999;
int e[N][N],dsp[N];
bool vst[N];
map<string,int> happy,cno;
map<int,string> city;

vector<vector<int>> pre;
vector<int> path,temppath;
//cost happy 当前路线经过几个点 
int tempsum = inf,temphappy = inf,tempcnt = 0;
int routcnt = 0;//线路数 

void dfs(int v,int hap){
	path.push_back(v);
	if(pre[v].size() == 0){
		int sum = 0;
		for(int i=0;i<path.size()-1;i++)
		{
			int a = path[i],b = path[i+1];
			sum += e[a][b];
		}
		if(tempsum < sum) 
			return;
		else if(tempsum > sum){
			tempsum = sum;
			temphappy = hap;
			temppath = path;
			tempcnt = path.size();
			routcnt = 1;
			return;
		}else{
			routcnt++;
			if(temphappy > hap)
				return;
			else if(temphappy < hap){
				temphappy = hap;
				temppath = path;
				tempcnt = path.size();
				return;
			}
			else{
				if(temphappy/tempcnt < hap/path.size()){
					temppath = path;
					tempcnt = path.size();
				}
				return ;
			}	
		}
	}
	
	for(int i=0;i<pre[v].size();i++){
		int n = happy[city[pre[v][i]]];
		dfs(pre[v][i],hap + n);
		path.pop_back();
	}	
}

int main(){
	fill(e[0],e[0]+N*N,inf);
	fill(dsp,dsp+N,inf);
	fill(vst,vst+N,0);
	
	int n,k;
	cin>>n>>k;
	pre.resize(n);
	
	string start;
	cin>>start;

	for(int i=0;i<n-1;i++)//注意是n-1 
	{
		string a;
		int b;
		cin>>a>>b;
		happy[a] = b;
	}
	cno[start] = 0;
	city[0] = start;
	int num = 1;
	for(int i=0;i<k;i++){
		string c1,c2;
		int dis;
		cin>>c1>>c2>>dis;		
		if(cno.find(c1) == cno.end()){
			cno[c1] = num;
			city[num] = c1;
			num++;
		}
			
		if(cno.find(c2) == cno.end()){
			cno[c2] = num;
			city[num] = c2;
			num++;
		}
		int a = cno[c1],b = cno[c2];
		e[a][b] = e[b][a] = dis;
	}
	
	dsp[cno[start]] = 0;
	for(int i=0;i<n;i++){
		int min = inf,u = -1;
		for(int j=0;j<n;j++)
			if(vst[j]==false && min > dsp[j])
			{
				u = j;
				min = dsp[j];
			}
		
		if(u == -1)break;
		vst[u] = true;
		for(int v=0;v<n;v++){
			if(vst[v] == false){
				if(dsp[u]+e[u][v] < dsp[v]){
					dsp[v] = dsp[u]+e[u][v];
					pre[v].clear();
					pre[v].push_back(u);
				}
				else if(dsp[u]+e[u][v] == dsp[v]){
					pre[v].push_back(u);
				}		
			}
		}	
	}
	dfs(cno["ROM"],happy["ROM"]);
	cout<<routcnt<<" "<<tempsum<<" "<<temphappy<<" "<<temphappy/(tempcnt-1)<<endl;
	for(int i=temppath.size()-1;i>=0;i--){
		cout<<city[temppath[i]];
		if(i != 0)
			cout<<"->";
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值