PAT甲级 1097 Deduplication on a Linked List (25 分)链表

113 篇文章 9 订阅
2 篇文章 0 订阅

1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Nextis the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

解析: 该题大意就是删除链表中的重复元素的结点, 重复元素是值相等或绝对值相等的。最后输出删除结点后的链表,接着输出所删除结点组成的链表。flag用于标记链表中结点的key是否有重复的。

细节: address 与 next 都要%05d形式打印。虽然题目说key <= 10的四次方,但还是要开到int flag[100000] 这么大,与node arr[100000]一样大,才能过一个点,并AC本题。

#include<iostream>
#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;

struct node{
	int add,key,next;
};

int main(){
	int fir,n;
	cin>>fir>>n;
	node arr[100000];
	
	int add,key,next;
	for(int i=0;i<n;i++){
		cin>>add>>key>>next;
		arr[add] = node{add,key,next};
	}
	
	vector<node> keep,move;
	int flag[100000] = {0};
	for(int i=fir;i != -1;i = arr[i].next){
		int num = abs(arr[i].key);
		if(flag[num] == 0){
			flag[num] = 1;
			keep.push_back(arr[i]);
		}else
			move.push_back(arr[i]);
	}
	
	for(int i=0;i<keep.size();i++){
		printf("%05d %d ",keep[i].add,keep[i].key);
		if(i == keep.size()-1)
			printf("-1\n");
		else
			printf("%05d\n",keep[i+1].add);
	}
	for(int i=0;i<move.size();i++){
		printf("%05d %d ",move[i].add,move[i].key);
		if(i == move.size()-1)
			printf("-1\n");
		else
			printf("%05d\n",move[i+1].add);
	}	
	
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值