PAT甲级 1116 Come on! Let's C (20 分)hash散列

113 篇文章 9 订阅
3 篇文章 0 订阅

1116 Come on! Let's C (20 分)

"Let's C" is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a "Mystery Award" (such as a BIG collection of students' research papers...).
  • 1、 Those who ranked as a prime number will receive the best award -- the Minions (小黄人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID's, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​4​​), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant's ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID's.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

题目大意:按排名输入id,接着查询。查询时第一名输出 Mystery Award ,排名是素数的输出 Minion,其它排名输出 Chocolate。注意已查询过的输出Are you kidding? 。

解题思路: 用hash散列来存储与查询即可,输入过程中直接判断对应奖项。用flag来标记是否已查询过。

#include<iostream>
#include<vector>
#include<cmath>
#include<cstdio>
using namespace std;

struct node{
	int rank;
	int award;
};

bool isprime(int num){
	for(int i=2;i<=sqrt(num);i++){
		if(num%i == 0)
			return false;
	}
	return true;
}

int main(){
	int n,m;
	cin>>n;
	node arr[10001];
	int flag[10001] = {0}; 
	int id,rank;
	for(int i=1;i<=n;i++){
		cin>>id;
		flag[id] = 1;
		arr[id].rank = i;
		if(i == 1)
			arr[id].award = 1;
		else{
			if(isprime(i))
				arr[id].award = 2;
			else
				arr[id].award = 3;
			}
	}
	cin>>m;
	for(int i=1;i<=m;i++){
		cin>>id;
		if(flag[id] == 0)
		    printf("%04d: Are you kidding?\n",id);
		else if(flag[id] == 1){
			if(arr[id].award == 1)
				printf("%04d: Mystery Award\n",id);
			else if(arr[id].award == 2)
				printf("%04d: Minion\n",id);
			else
				printf("%04d: Chocolate\n",id);
			flag[id] = 2;
		}else
			printf("%04d: Checked\n",id);	
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值