Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2 10 15 5 1 3 5 10 7 4 9 2 8 5 11 1 2 3 4 5
Sample Output
2 3
题意:T组实例,每组实例给出n和s,接着n个数。求连续子序列和大于等于s的最短子序列长度。
分析:有点模拟的意思,形象点说,就像你堆积木,超过一定值S后我们就把最下面的几块积木去掉。具体方法是从前面开始不断累加,当和值超过S时减少前面的数值,然后记录下刚好>=S的ans值,如此重复直到序列尾,输出最小的ans。
#include<iostream>
#include<vector>
using namespace std;
int main(){
int m,n,s;
cin>>m;
while(m--){
cin>>n>>s;
vector<int> vec(n+1),dsp(n+1,0);
for(int i=1;i<=n;i++)
cin>>vec[i];
for(int i=1;i<=n;i++)
dsp[i] = dsp[i-1]+vec[i];
if(dsp[n] < s)
cout<<0<<endl;
else{
int i = 0,minn = 9999999;
for(int j=1;j<=n;j++)
{
if(dsp[j] - dsp[i] < s){
continue;
}
while(dsp[j]-dsp[i+1] >= s)
i++;
minn = min(minn,j-i);
}
cout<<minn<<endl;
}
}
}