HUD 2818


Building Block


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command. 
C X : Count the number of blocks under block X 

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 


Sample Output
  
  
1 0 2
#include<iostream>
#include<cstdio>

using namespace std;

const int MAX=30005;
int pre[MAX],num[MAX],under[MAX];//num[X]:X是集合代表,某个堆(集合)中Piles的总数
                            //under[i]: 编号为i的Pile下面有多少个Piles (一边进行查找,一边更新)

int findFather(int x)
{
    int tmp;
    if(pre[x]!=x)
    {
        tmp=findFather(pre[x]);//递归过程自底向上自动更新under[],递归基础:下面的under[X] = num[Y]
        under[x]+=under[pre[x]];//现在x下面的方块数是它所有祖先下面方块的总和
        pre[x]=tmp;
    }
    return pre[x];
}
void join(int x,int y)
{
    int fx=findFather(x);
    int fy=findFather(y);
    if(fx!=fy)
    {
        under[fx]=num[fy];//X放在Y上,X是当前堆(集合)中最底部的,直接更新under[]
        num[fy]+=num[fx]; //直接更新Y这堆(集合)的高度(总共多少个Piles)
        pre[fx]=fy;//合并,注意是X加到Y上,不同于一般的并查集的father[Y]=X
    }
}
int main()
{
    int N;
    while(~scanf("%d",&N))
    {
        char oper[5];
        int m,n;
        for(int i=0;i<=MAX;i++)
        {
            pre[i]=i;
            num[i]=1;
            under[i]=0;
        }
        for(int i=1;i<=N;i++)
        {
            scanf("%s",oper);
            if(oper[0]=='M')
            {
                scanf("%d%d",&m,&n);
                join(m,n);
            }
            else
            {
                scanf("%d",&m);
                findFather(m);      //可能在进行C操作时m的并集中有新元素加入,所以要重新算under
                printf("%d\n",under[m]);
            }
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值