将所有边排序,按边权从小到大,如果当前的边的端点还没有连接,就把这条边加上,判断是否连接当然是用神奇的并查集啦
题目描述 Description
农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。 约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了使花费最少,他想铺设最短的光纤去连接所有的农场。 你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。 每两个农场间的距离不会超过100000
输入描述 Input Description
第一行: 农场的个数,N(3<=N<=100)。
第二行…结尾: 接下来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们每行限制在80个字符以内,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为线路从第i个农场到它本身的距离在本题中没有意义。
输出描述 Output Description
只有一个输出,是连接到每个农场的光纤的最小长度和。
样例输入 Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
样例输出 Sample Output
28
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string>
#include<queue>
#include<cmath>
#define INF 0x3f3f3f3f;
using namespace std;
struct node
{
int s,ti,z;
}t[100100];
int f[1010],x,n,S,ans,tot;
int find(int x)
{
if(f[x] == x) return x;
f[x] = find(f[x]);
return f[x];
}
bool cmp(node k,node l)
{
return k.z < l.z;
}
int main()
{
scanf("%d",&n);
tot = 0;
for(int i = 1;i <= n; ++i)
{
for(int j = 1;j <= n; ++j)
{
scanf("%d",&x);
t[tot].s = i;
t[tot].ti = j;
t[tot].z = x;
tot++;
}
f[i] = i;
}
sort(t , t + tot ,cmp);
S = 0;
ans = 0;
for(int i = 0;i < tot; ++i)
{
if(find(t[i].s) != find(t[i].ti))
{
f[find(t[i].s)] = find(t[i].ti);
ans += t[i].z;
S++;
}
if(S == n - 1) break;
}
printf("%d\n",ans);
return 0;
}