HD 1789 Doing Homework again【贪心】

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8893    Accepted Submission(s): 5245


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 
<span style="font-size:24px;"><strong>AC代码:</strong></span>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
int b[1001];
struct st
{
	int d,s;
}a[1001];
int cmp(st x,st y)
{
	return x.s>y.s;
}
int main()
{
	int k,i,j;
	scanf("%d",&k);
	while(k--)
	{
		int n,ans=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		scanf("%d",&a[i].d);
		for(i=0;i<n;i++)
		scanf("%d",&a[i].s);
		sort(a,a+n,cmp);
        memset(b,0,sizeof(b));//如果当天没用过,值为0;否则为1
        for(i=0;i<n;i++)
        {
        	j=a[i].d;// 从截止时间开始往前推,如果有一天没用过,这一天就做这一门课,这门课不扣分
        	while(j)
        	{
        		if(!b[j])
        		{
	        		b[j]=1;
	        		break;
				}
				j--;
			}
		    if(j==0)//如果j=0,表明从time往前的每一天都被占用了,这门课完不成 . 
		    ans+=a[i].s;
		}
		printf("%d\n",ans);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值