hdoj--5562--Clarke and food(模拟)

159 篇文章 0 订阅

Clarke and food

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 620    Accepted Submission(s): 361



Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a cook, was shopping for food.
Clarke has bought n food. The volume of the i th food is vi . Now Clarke has a pack with volume V . He wants to carry food as much as possible. Tell him the maxmium number he can brought with this pack.
 

Input
The first line contains an integer T(1T10) , the number of the test cases.
For each test case:
The first line contains two integers n,V(1n105,1V109) .
The second line contains n integers, the i th integer denotes vi(1vi109) .
 

Output
For each test case, print a line with an integer which denotes the answer.
 

Sample Input
  
  
1 3 5 1 3 4
 

Sample Output
  
  
2 Hint: We can carry 1 and 3, the total volume of them is 5.
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int num[100100];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,v;
		memset(num,0,sizeof(num)); 
		scanf("%d%d",&n,&v);
		for(int i=0;i<n;i++)
		scanf("%d",&num[i]);
		sort(num,num+n);
		int i;
		for(i=0;i<n;i++)
		{
			if(v-num[i]<0)
			break;
			else
			v-=num[i];
		}
		printf("%d\n",i);
	}
	return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值