HZAU--21--Arithmetic Sequence(二维dp)



Arithmetic Sequence

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 1815   Solved: 315
[ Submit][ Status][ Web Board]

Description

    Giving a number sequence A with length n, you should choosing m numbers from A(ignore the order) which can form an arithmetic sequence and make m as large as possible.

Input

   There are multiple test cases. In each test case, the first line contains a positive integer n. The second line contains n integers separated by spaces, indicating the number sequence A. All the integers are positive and not more than 2000. The input will end by EOF.

Output

   For each test case, output the maximum  as the answer in one line.

Sample Input

5
1 3 5 7 10
8
4 2 7 11 3 1 9 5

Sample Output

4
6

HINT



   In the first test case, you should choose 1,3,5,7 to form the arithmetic sequence and its length is 4.


   In the second test case, you should choose 1,3,5,7,9,11 and the length is 6.

找出最长的等差序列,输出长度

二维dp,第二维记录公差

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int num[2020],dp[2020][2020];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(num,0,sizeof(num));
		for(int i=0;i<2020;i++)
		{
			for(int j=0;j<2020;j++)
			dp[i][j]=1;
		}
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&num[i]);
		}
		sort(num+1,num+n+1);
		int ans=1;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<i;j++)
			{
				int d=num[j]-num[i];
				dp[i][d]=max(dp[i][d],dp[j][d]+1);
				ans=max(dp[i][d],ans);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值