PAT(stl)——1063. Set Similarity (25)

6 篇文章 0 订阅

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:
50.0%
33.3%

题目大意:

求出指定两个集合nc(两集合间共同元素)/nt(两集合不同元素总和)的值。

题目解析:

set的使用。

具体代码:
#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
set<int> s[55];
double common(set<int> a,set<int> b){
	set<int>::iterator ta=a.begin();
	set<int>::iterator tb=b.begin();
	int res=0;
	while(ta!=a.end()&&tb!=b.end()){
		if(*ta==*tb){
			res++;
			ta++;
			tb++;
		}else if(*ta<*tb)
			ta++;
		else
			tb++;
	}
	return (double)res;
}
int main()
{
    int n,m;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
    	int num;
    	scanf("%d",&num);
    	for(int j=0;j<num;j++){
    		int number;
    		scanf("%d",&number);
    		s[i].insert(number);
		}
	}
	scanf("%d",&m);
	for(int i=1;i<=m;i++){
		int a,b;
		scanf("%d%d",&a,&b);
		double nc=common(s[a],s[b]);
		double nt=s[a].size()+s[b].size()-nc;
		printf("%.1f%\n",nc/nt*100);
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值