PAT(并查集)——1118. Birds in Forest (25)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<= 104) which is the number of pictures. Then N lines follow, each describes a picture in the format:
K B1 B2 … BK
where K is the number of birds in this picture, and Bi’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 104.

After the pictures there is a positive number Q (<= 104) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line “Yes” if the two birds belong to the same tree, or “No” if not.

Sample Input:
4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7
Sample Output:
2 10
Yes
No

题目大意:

有几组照片,同一张照片上出现的鸟在同一棵树上,求最多几棵树,一共几只鸟,以及任意给两只鸟,求是否在同一棵树上。

题目解析:

并查集的题目,为了记录鸟儿的编号,可以使用set来存储鸟儿编号,因为多次出现的鸟儿只记录一个。

具体代码:
#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
#define MAXN 10005
int parent[MAXN];
set<int> birds;
int num[MAXN];
int find_parent(int x){
	int a=x;
	while(x!=parent[x])
		x=parent[x];
	while(a!=parent[a]){//路径压缩 
		int b=a;
		parent[b]=x;
		a=parent[a];
	}
	return x;
}
void Union(int a,int b){
	int fa=find_parent(a);
	int fb=find_parent(b);
	if(fa!=fb){
		parent[fa]=fb;
	}
}
int main()
{
    int n;
    cin>>n;
    for(int i=0;i<MAXN;i++)
    	parent[i]=i;
    for(int i=0;i<n;i++){
    	int k,first;
    	cin>>k>>first;
    	birds.insert(first);
    	for(int j=0;j<k-1;j++){
    		int tmp;
    		cin>>tmp;
    		birds.insert(tmp);
    		Union(first,tmp);
		}
	}
	for(auto it=birds.begin();it!=birds.end();it++){
		int root=find_parent(*it);
		num[root]++;
	}
	int tree_num=0,bird_num=0;
	for(auto it=birds.begin();it!=birds.end();it++){
		if(num[*it]!=0){
			tree_num++;
			bird_num+=num[*it];
		}
	}
	cout<<tree_num<<" "<<bird_num<<endl;
	cin>>n;
	for(int i=0;i<n;i++){
		int a,b;
		cin>>a>>b;
		if(find_parent(a)==find_parent(b))
			cout<<"Yes"<<endl;
		else
			cout<<"No"<<endl;
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值