按位求和 CSU - 1161 Sums

Description

Sometimes Ziwen need to operate even larger numbers. A limit of 1000 digits is so small… You have to find the sum of two numbers with maximal size of 1 000 000 digits.

Input

The first line contains a single integer N that is the length of the given integers(1 ≤ N ≤ 1 000 000). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 0, and the length of their sum does not exceed N. The integers may contain leading zeroes.

Output

Output exactly N digits in a single line representing the sum of these two integers.

Sample Input

 
4
0 4
4 2
6 8
3 7

Sample Output

4750

代码:

#include<iostream>
//Sums CSU - 1161
using namespace std;
int array1[2000010];
int main() 
{
	int N;
	cin >> N;
	//int array[2000010];
	for (int i = 0; i < N; i++)
	{
		cin >> array1[i] >> array1[i + 1000000];//array指向不明确
	}
	
	int temp, b=0;//暂时保存两位之和,b保存十位上的数
	for (int i = N-1; i >= 0; i--)
	{
		temp = array1[i] + array1[i + 1000000] + b;//加上b哦
		array1[i] = temp % 10;
		b = temp / 10;
	}

	for (int i = 0; i < N; i++)
	{
		cout << array1[i];
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值