POJ2192(Zipper)

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

AC代码

#include <iostream>
#include <string>
using namespace std;

int main()
{
    int N;
    cin>>N;
    for ( int i = 1 ; i <= N ; i++){
        string str1;
        string str2;
        string str; 
        int ok[201][201] = {0};
         /********************** 
                      ok[i][j]为真时表示str1的前i个字符可以和str2的前j个字符 
                          组成str3的前i+j个字符。为假时 表示不能。 
                    ***********************/  
        cin>>str1>>str2>>str;
        int len1 = str1.length();
        int len2 = str2.length();
        ok[0][0] = 1;

        for ( int j = 1 ; j <= len1 ; j++){
            if (ok[j-1][0] == 1 && str1[j-1] == str[j-1]){
                ok[j][0] = 1;
            }else{
                break;
            }
        }
        for ( int j = 1 ; j <= len2 ; j++){
            if (ok[0][j-1] == 1 && str2[j-1] == str[j-1]){
                ok[0][j] = 1;
            }else{
                break;
            }
        }

        for (int j = 1 ; j <= len1 ; j++){
            for ( int k = 1 ; k <= len2 ; k++){
                if ((ok[j-1][k] == 1 && str1[j-1] == str[j+k-1]) || (ok[j][k-1] == 1 && str2[k-1] == str[j+k-1])){
                    ok[j][k] = 1;
                }
            }
        }

        if ( ok[len1][len2] == 1){
            cout<<"Data set "<<i<<": yes"<<endl;
        }else{
            cout<<"Data set "<<i<<": no"<<endl;
        }
    } 

    return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

daipuweiai

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值