04-树6 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 1000≤1000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4


思路:
这个题想了好久,最后还是看别人的代码才明白了,就是根据完全二叉树的性质,完全二叉树在数组中某个节点的下标为i,则其左右孩子的下标分别为2*1,2*i+1。然后递归建树。


AC代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

int pos = 0;
int root = 1;
int N;
vector<int> CBT;
vector<int> AVL;

void Build_CBT(int root)
{
    if ( root > N){
        return;
    }else{
        int left = 2 * root;
        int right = 2 * root + 1;
        Build_CBT(left);
        CBT[root] = AVL[pos++];
        Build_CBT(right);
    }
}

int main()
{
    cin>>N;
    AVL = vector<int>(N,0);
    CBT = vector<int>(N+1,0);

    for ( int i = 0 ; i < N ; i++){
        cin>>AVL[i];
    }
    sort(AVL.begin(),AVL.end());

    Build_CBT(root);

    cout<<CBT[1];
    for ( int i = 2 ; i < CBT.size() ; i++){
        cout<<" "<<CBT[i];
    }


    return 0;
 } 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

daipuweiai

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值