九度OJ——1014排名

题目描述:
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的考生,并将他们的成绩按降序打印。
输入:
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N < 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
输出:
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考号的升序输出。
样例输入:
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
样例输出:
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20


全部代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
using namespace std;

typedef struct student{
    string id;
    int grade;
}Student;

int cmp(Student s1,Student s2)
{
    if(s1.grade != s2.grade){
        return s1.grade>s2.grade;
    }else{
        return s1.id.compare(s2.id)<0;
    }
}

vector<Student> students(1000);
int score[1000];
int N,M,G,m,sum,tmp,cnt;
string id;

int main()
{
    while(~scanf("%d",&N)){
        if(N == 0){//学生数为0,停止输入 
            break;
        }
        cin>>M>>G;
        students.clear();
        for(int i = 1 ; i <= M ; i++){
            cin>>score[i];
        }
        cnt = 0;
        for(int i = 0 ; i < N ; i++){
            sum = 0;
            cin>>id>>m;
            for(int j = 0 ; j < m ; j++){
                cin>>tmp;
                sum += score[tmp]; 
            }
            if(sum >= G){
                cnt++;
            }
            Student s;
            s.id = id;
            s.grade = sum;
            students.push_back(s);
        }
        if(N != 0){
            cout<<cnt<<endl;    
            sort(students.begin(),students.end(),cmp);
            if(cnt > 0){
                for(int i = 0 ; i < cnt ; i++){
                    cout<<students[i].id<<" "<<students[i].grade<<endl;
                }       
            }   
        }   
    }


    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

daipuweiai

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值