PTA-Calculating an expression

30 篇文章 12 订阅

                                   Calculating an expression

Given an mathematic expression, you soppose to print out the value of this espression.

Input Specification:

Given an mathematic expression, include 2 integer operands and 1 operator (+,-,*,/ ). No extra space allowed.

Output Specification:

Output the answer. If the operator is "/", keep 2 decimal digits behind point; else, output in integer.

Sample Input 1:

10+15

Sample Output 1:

25

Sample Input 2:

5/3

Sample Output 2:

1.67

 

解答:

#include <stdio.h>
int main()
{
    double a, b, c;
    char op;
    scanf("%lf %c %lf",&a, &op, &b);
    switch(op){
        case '+':
            c = a + b;
            printf("%.0f\n", c);
            break;
        case '-':
            c = a - b;
            printf("%.0f\n", c);
            break;
        case '*':
            c = a * b;
            printf("%.0f\n", c);
            break;
        case '/':
            c = a / b;
            printf("%.2f\n", c);
            break;
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

踏雪无痕是个小疯子

您的鼓励将促使我的创作更有价值

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值