hdu Card Game

Card Game

Soda and Beta are good friends. They are going to play a card game today. Soda has nn cards with number a1,a2,…,ana1,a2,…,an while Beta has nn cards with number b1,b2,…,bnb1,b2,…,bn.

First, they choose a number mm no larger than nn. Then they both randomly select mm cards from their own nn cards. The one with larger sum of the selected cards will win. Soda wants to know if he can always win no mater what cards will be randomly selected from him and Beta.
Input
There are multiple test cases. The first line of input contains an integer T(1≤T≤100)T(1≤T≤100), indicating the number of test cases. For each test case:

The first line contains two integer nn and mm (1≤m≤n≤500)(1≤m≤n≤500). The second line contains nn integers a1,a2,…,ana1,a2,…,an (1≤ai≤1000)(1≤ai≤1000) denoting Soda’s cards. The third line contains nn integers b1,b2,…,bnb1,b2,…,bn (1≤bi≤1000)(1≤bi≤1000) denoting Beta’s cards.
Output
For each test case, output “YES” (without the quotes) if Soda can always win, otherwise output “NO” (without the quotes) in a single line.
Sample Input
2
3 1
4 5 6
1 2 3
5 2
3 4 7 8 9
3 4 5 2 3
Sample Output
YES
NO

//这题额,水,,,给两个数组
让你判断一组数当中任意取几个数恒大于另一组

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int x[1003],y[1003];
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x[i]);
        }
        for(int j=0;j<n;j++)scanf("%d",&y[j]);
        sort(x,x+n);
        sort(y,y+n);
        int sum1=0,sum2=0;
        for(int i=0;i<m;i++)
            sum1+=x[i];
        for(int j=n-1;j>=n-m;j--)
        {
            sum2+=y[j];
        }
        if(sum1>sum2)
            printf("YES\n");
        else printf("NO\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值