zoj Circle

并查集问题。给出n个点n对连接关系

我们需要判断它是否能够构成一个类似圆的图形(带边的封闭图形)

这个时候我们需要用并查集

并查集记得加路径优化

我们需要知道封闭图形每个点只能与两个点相连。

而且这个封闭图形由n个点组成

Your task is so easy. I will give you an undirected graph, and you just need to tell me whether the graph is just a circle. A cycle is three or more nodes V1V2V3, ... Vk, such that there are edges between V1 and V2V2 and V3, ... Vk and V1, with no other extra edges. The graph will not contain self-loop. Furthermore, there is at most one edge between two nodes.

Input

There are multiple cases (no more than 10).

The first line contains two integers n and m, which indicate the number of nodes and the number of edges (1 < n < 10, 1 <= m < 20).

Following are m lines, each contains two integers x and y (1 <= xy <= nx != y), which means there is an edge between node x and node y.

There is a blank line between cases.

Output

If the graph is just a circle, output "YES", otherwise output "NO".

Sample Input

3 3
1 2
2 3
1 3

4 4
1 2
2 3
3 1
1 4

Sample Output

YES
NO
上代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<ctype.h>
#include<stack>
#include<queue>
using namespace std;
int f[1003],num[1003],ans[1003];
int join(int x)
{
    return (x==f[x])?x:join(f[x]);//并查集的查,外加路径压缩
}
void coin(int x,int y)//并
{
    int xx=join(x);
    int yy=join(y);
    if(xx!=yy)
    {
        ans[xx]+=ans[yy];//每次建立新的联系祖先点都需要将分支点的所包含的子点数加起来

        f[yy]=xx;
    }
}

//我们需要记录每个点出现的次数

//我们需要借助祖先点


int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int flag=0;
        memset(num,0,sizeof(num));
        for(int i=1; i<=n; i++)f[i]=i,ans[i]=1;
        int a,b;
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            if(a==b)
            {
                flag=1;
            }
            num[a]++;
            num[b]++;
            coin(a,b);
        }
        for(int i=1; i<=n; i++)
        {
            int z=join(i);
            if(num[i]!=2||ans[z]!=n)
            {
                //printf("%d %d\n",i,ans[z]);
                flag=1;
                break;
            }
        }
        if(flag)
            printf("NO\n");
        else printf("YES\n");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值