FZU - 2214 Knapsack problem (dp(对价值dp))

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input
1
5 15
12 4
2 2
1 1
4 10
1 2
Sample Output
15

Hint


通过题中的数据范围可知,,对w dp是不可行的。。。

对vdp

这就很尴尬了。。。

(1-n)dp[i] = inf;

dp[0]=0;

dp[v]=w;

开始的时候除了0价值的所需要重量是0

其他的价值都是无穷大

让后我们开始dp

从第一个开始。

dp[j]=min(dp[j],dp[j-v[i]]+w[i]);

每一个价值选取重量最小的价值更新上去

(从后往前dp这是01背包)(从前往后是完全背包)

(这里需要的是01 背包)

for(int i=0;i<n;i++)

{

for(int j=max_v;j>=v[i];j--)

{

dp[j]=min(dp[j],dp[j-v[i]]+w[i]);

}

}

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 500*1000000000
int w[10003];
int v[10003];
long long dp[5005];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        int sv=0;
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&w[i],&v[i]);
            sv+=v[i];
        }
        dp[0]=0;
        for(int i=1;i<=sv;i++)
        {
            dp[i]=N;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=sv;j>=v[i];j--)
            {
                dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
            }
        }
        for(int i=sv;i>=0;i--)
        {
            if(dp[i]<=m)
            {
                printf("%d\n",i);
                break;
            }
        }
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值