hdu 2859 Phalanx(二位动态规划)

Phalanx

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2064    Accepted Submission(s): 1014


Problem Description
Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC.
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position.
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs.
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix:
cbx
cpb
zcc
 

Input
There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.
 

Output
Each test case output one line, the size of the maximum symmetrical sub- matrix.
 

Sample Input
      
      
3 abx cyb zca 4 zaba cbab abbc cacq 0
 

Sample Output
      
      
3 3
 

Source
 

Recommend
gaojie





题意:

给你一个n*n矩阵问你最大的关于左下到右上的对称子阵的边的大小


看了一下最小是1 /。///这里wa了7发。。

然后二维背包跑一下就出了

xx --》xxx

xx       xxx

          xxx

就是添加了一个竖行一个横行

然后判断添加是否相等。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char m[1003][1003];
int dp[1003][1003];
int main()
{
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
        {
            scanf("%s",m[i]+1);
        }
        int res=1;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                if(i==1||j==n)
                {
                    dp[i][j]=1;
                    continue;
                }
                int tx=i-1;
                int ty=j+1;
                int tmp;
                while(tx>=1&&ty<=n&&m[i][ty]==m[tx][j])
                {
                    tx--;
                    ty++;
                }
                tmp=i-tx;
                if(tmp>dp[i-1][j+1])
                    dp[i][j]=dp[i-1][j+1]+1;
                else dp[i][j]=tmp;
                res=max(dp[i][j],res);
            }
        }
        printf("%d\n",res);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值