python中wordcloud的安装

6人阅读 评论(0) 收藏 举报
分类:

网上试了很多方法,没有解决,

“error: Microsoft Visual C++ 14.0 is required…”问题解决

今天在Python 3.6环境中,制作词云,需要安装wordcloud模块,在安装的过程中遇到了“error: Microsoft Visual C++ 14.0 is required…” 的问题,很是烦恼,最后找到了一个解决办法:

这里写图片描述

常规的安装模块包都是通过:

1
2
3
4
5
6
7
8
9
10
11
pip install xxx
conda install xxx
github下载并解压:
wget https://github.com/amueller/word_cloud/archive/master.zip
unzip master.zip
rm master.zip
cd word_cloud-master
安装依赖包:
sudo pip install -r requirements.txt
安装wordcloud
python setup.py install

方法一二都尝试了,都失败。方法三建立连接失败。于是还是按照方法三的思想,到 https://www.lfd.uci.edu/~gohlke/pythonlibs/ 页面下载所需的wordcloud模块的whl文件,下载后进入存储该文件的路径,按照方法一,执行“pip install wordcloud-1.2.1-cp36-cp36m-win_amd64.whl”,这样就会安装成功。


查看评论

microsoft visual c++ 14.0 is required问题解决办法

pip install pymssql时出错: error: Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Vis...
  • amoscn
  • amoscn
  • 2017-10-12 15:41:44
  • 13980

python 报错Microsoft Visual C++ 14.0 is required

原因: 可能是直接使用 pip install 【第三方库名】 安装自己需要的第三方库。结果错误: Microsoft Visual C++ 14.0 is required解决办法: 一定...
  • TH_NUM
  • TH_NUM
  • 2017-08-11 11:52:54
  • 13563

Microsoft Visual C++ 14.0

  • 2018年03月29日 10:58
  • 2.78MB
  • 下载

Microsoft visual c++ 14.0 is required问题解决办法

用pip 安装库报错:Microsoft visual c++ 14.0 is required下载安装包安装即可:Microsoft visual c++ 14.0...
  • qq_38316655
  • qq_38316655
  • 2018-03-01 21:49:37
  • 842

Python 3.6 模块安装“error: Microsoft Visual C++ 14.0 is required...”问题解决

今天在Python 3.6环境中,制作词云,需要安装wordcloud模块,在安装的过程中遇到了“error: Microsoft Visual C++ 14.0 is required…” 的问题,...
  • u011389474
  • u011389474
  • 2017-03-07 15:04:48
  • 34191

Windows下配置scrapy,error,Microsoft Visual C++ 14.0 is required

这个错误说明:环境依赖于 microsoft visual C++ 14.0, 仔细看报错后面还写着该C++库的下载地址;因此,去提示的链接地址, 老老实实 下载该库就可以正常配置,不会报错了。...
  • MrWilliamVs
  • MrWilliamVs
  • 2017-08-12 21:03:34
  • 7542

pip install scrapy安装时出错microsoft visual c++ 14.0 is required

pip install scrapy安装Twisted时出错Microsoft Visual C++ 14.0 is required. Get it with “Microsoft Visual C...
  • winner_looser
  • winner_looser
  • 2018-04-10 20:05:41
  • 166

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http:/

Python在下载包的过程中遇到 error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ ...
  • HHTNAN
  • HHTNAN
  • 2017-09-11 12:16:53
  • 12068

一步一步安装scrapy框架

这个安装教程比较实用······· 首先考虑使用最简单的方法安装 [plain] view plain copy pip install scrapy 命令安装,提示 Failed bui...
  • Travelerwz
  • Travelerwz
  • 2018-04-19 10:59:41
  • 27

pip安装pycrypto报错:Microsoft Visual C++ 14.0 is required. 的解决办法

环境:Win10 64位,Python版本 3.6在CMD命令行用 pip.exe install pycrypto 安装PyCrypto模块时报错:error: Microsoft Visual C...
  • woay2008
  • woay2008
  • 2018-04-12 00:36:11
  • 149
    个人资料
    持之以恒
    等级:
    访问量: 12万+
    积分: 4753
    排名: 7627
    最新评论