hdu4849



Wow! Such City!

Time Limit: 15000/8000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1544    Accepted Submission(s): 545


Problem Description
Doge, tired of being a popular image on internet, is considering moving to another city for a new way of life.
In his country there are N (2 ≤N≤ 1000) cities labeled 0 . . . N - 1. He is currently in city 0. Meanwhile, for each pair of cities, there exists a road connecting them, costing C i, j (a positive integer) for traveling from city i to city j. Please note that C i, j may not equal to C j, i for any given i ≠ j.
Doge is carefully examining the cities: in fact he will divide cities (his current city 0 is NOT included) into M (2 ≤ M ≤ 10 6) categories as follow: If the minimal cost from his current city (labeled 0) to the city i is Di, city i belongs to category numbered Di mod M.Doge wants to know the “minimal” category (a category with minimal number) which contains at least one city.
For example, for a country with 4 cities (labeled 0 . . . 3, note that city 0 is not considered), Doge wants to divide them into 3 categories. Suppose category 0 contains no city, category 1 contains city 2 and 3, while category 2 contains city 1, Doge consider category 1 as the minimal one.
Could you please help Doge solve this problem?

Note:

C i, j is generated in the following way:
Given integers X 0, X 1, Y 0, Y 1, (1 ≤ X 0, X 1, Y 0, Y 1≤ 1234567), for k ≥ 2 we have
Xk  = (12345 + X k-1 * 23456 + X k-2 * 34567 + X k-1 * X k-2 * 45678)  mod  5837501
Yk  = (56789 + Y k-1 * 67890 + Y k-2 * 78901 + Y k-1 * Y k-2 * 89012)  mod  9860381
The for k ≥ 0 we have

Z k = (X k * 90123 + Y k ) mod 8475871 + 1

Finally for 0 ≤ i, j ≤ N - 1 we have

C i, j = Z i*n+j for i ≠ j
C i, j = 0   for i = j
 

Input
There are several test cases. Please process till EOF.
For each test case, there is only one line containing 6 integers N,M,X 0,X 1,Y 0,Y 1.See the description for more details.
 

Output
For each test case, output a single line containing a single integer: the number of minimal category.
 

Sample Input
  
  
3 10 1 2 3 4 4 20 2 3 4 5
 

Sample Output
  
  
1 10 For the first test case, we have 0 1 2 3 4 5 6 7 8 X 1 2 185180 788997 1483212 4659423 4123738 2178800 219267 Y 3 4 1633196 7845564 2071599 4562697 3523912 317737 1167849 Z 90127 180251 1620338 2064506 625135 5664774 5647950 8282552 4912390 the cost matrix C is 0 180251 1620338 2064506 0 5664774 5647950 8282552 0
Hint
So the minimal cost from city 0 to city 1 is 180251, while the distance to city 2 is 1620338. Given M = 10, city 1 and city 2 belong to category 1 and 8 respectively. Since only category 1 and 8 contain at least one city, the minimal one of them, category 1, is the desired answer to Doge’s question.
 

Source

题意:

        给你一个计算公式,要你算出N个顶点的图的任意两点间的距离,然后要你求0号点到所有其他点的最短距离,然后要你输出这些最短距离中%m最小的值即可.

分析:

        注意一下计算任意两个城市之间距离的时候不要算数溢出即可.

        然后用Dijkstra算法模板即可.

       注意本题是稠密图,所以直接用矩阵的Dijkstra算法了.

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<queue>
long long  INF = 0x7fffffff;
using namespace std;
const int maxn=1000+10;
long long n,m;
long long x[maxn*maxn],y[maxn*maxn],z[maxn*maxn];//这里数组开成了maxn导致一直WA
long long cost[maxn][maxn];
void init()
{
    z[0]= (x[0] * 90123 + y[0] )%8475871 + 1;
    z[1]= (x[1] * 90123 + y[1] )%8475871 + 1;
    for(int i=2;i<n*n;i++)
    {
        x[i] = ( (12345)+(x[i-1]*23456)%5837501+(x[i-2]*34567)%5837501+ ((x[i-1]*x[i-2])%5837501)*45678 )%5837501;
        y[i] = ( (56789)+(y[i-1]*67890)%9860381+(y[i-2]*78901)%9860381+ ((y[i-1]*y[i-2])%9860381)*89012 )%9860381;
        z[i] = (x[i] * 90123 + y[i] )%8475871 + 1;
    }
    for(int i=0;i<n;i++)
    for(int j=0;j<n;j++)
    {
        if(i==j) cost[i][j]=0;
        else cost[i][j] = z[i*n+j];
    }
}
bool done[maxn];
long long d[maxn];
void dijkstra()
{
    memset(done,0,sizeof(done));
    for(int i=0;i<n;i++) d[i]= INF;
    d[0]=0;
    for(int i=0;i<n;i++)
    {
        long long x,m=INF;
        for(int y=0;y<n;y++)if(!done[y]&&d[y]<=m) m=d[x=y];
        done[x]=true;
        for(int y=0;y<n;y++)d[y] = min(d[y],d[x]+cost[x][y]);
    }
}

int main()
{
    while(scanf("%I64d%I64d%I64d%I64d%I64d%I64d",&n,&m,&x[0],&x[1],&y[0],&y[1])==6)
    {
        init();
        dijkstra();
        long long ans=INF;
        for(int i=1;i<n;i++)
            ans = min(ans,d[i]%m);
        printf("%I64d\n",ans);
    }
    return 0;
}
</span>








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值