PTA 7-50 推断学生所属学校的人数 (25分) 并查集模板 统计联通块个数

某个比赛现场有来自不同学校的N名学生,给出M对“两人同属一所学校”的关系, 请推断学校数量,并找出人数最多的学校。
输入格式:

第一行是一个在[2, 1000]范围的整数N,

接下来N行,每行是一个在现场的学生的姓名,每个姓名仅由字母组成,长度不超过30。

接下来一行是非负整数M,表示有M对关系;

然后是M行,每行是用空格间隔的两个人名,表示同属一所学校。
输出格式:

在一行内分别输出学校的数量以及人数最多学校的人数,用一个空格分隔。
输入样例:

8
Bill
Ellen
Ann
Chris
Daisy
Flin
Henry
Grace
5
Ann Chris
Ellen Chris
Daisy Flin
Henry Ellen
Grace Flin

输出样例:

3 4

  • 使用sum[i]表示根为i的联通块的个数
  • 初始化sum[i]=1
  • 合并xy时,sum[fa(x)]+=sum[fa(y)]
#define debug
#ifdef debug
#include <time.h>
#include "/home/majiao/mb.h"
#endif

#include <iostream>
#include <algorithm>
#include <vector>
#include <string.h>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <math.h>

#define MAXN ((int)1e5+7)
#define ll long long 
#define INF (0x7f7f7f7f)
#define fori(lef, rig) for(int i=lef; i<=rig; i++)
#define forj(lef, rig) for(int j=lef; j<=rig; j++)
#define fork(lef, rig) for(int k=lef; k<=rig; k++)
#define QAQ (0)

using namespace std;

#define show(x...)                             \
    do {                                       \
        cout << "\033[31;1m " << #x << " -> "; \
        err(x);                                \
    } while (0)

void err() { cout << "\033[39;0m" << endl; }
template<typename T, typename... A>
void err(T a, A... x) { cout << a << ' '; err(x...); }

namespace FastIO {

	char print_f[105];
	void read() { }
	void print() { putchar('\n'); }

	template <typename T, typename... T2>
		inline void read(T &x, T2 &... oth) {
			x = 0;
			char ch = getchar();
			ll f = 1;
			while (!isdigit(ch)) {
				if (ch == '-') f *= -1; 
				ch = getchar();
			}
			while (isdigit(ch)) {
				x = x * 10 + ch - 48;
				ch = getchar();
			}
			x *= f;
			read(oth...);
		}
	template <typename T, typename... T2>
		inline void print(T x, T2... oth) {
			ll p3=-1;
			if(x<0) putchar('-'), x=-x;
			do{
				print_f[++p3] = x%10 + 48;
			} while(x/=10);
			while(p3>=0) putchar(print_f[p3--]);
			putchar(' ');
			print(oth...);
		}
} // namespace FastIO
using FastIO::print;
using FastIO::read;

int n, m, Q, K, tot;

map<string, int> mp;

int ID(string& str) {
	int& rx = mp[str];
	if(rx == 0) rx = ++ tot;
	return rx;
}

int pre[MAXN], sum[MAXN];
int fa(int x) {
	return (x==pre[x]) ? x : (pre[x]=fa(pre[x]));
}

void union_xy(int x, int y) {
	int rx = fa(x), ry = fa(y);
	if(x != y) {
		sum[rx] += sum[ry];
		pre[ry] = rx;
	}
}

int main() {
#ifdef debug
	freopen("test", "r", stdin);
	// freopen("out_main", "w", stdout);
	clock_t stime = clock();
#endif
	cin >> n;
	for(int i=1; i<=n; i++) {
		string str;
		cin >> str;
		ID(str);
	}
	n = tot;
	cin >> m;
	for(int i=1; i<=n; i++) pre[i] = i, sum[i] = 1;
	while(m--) {
		string sa, sb;
		cin >> sa >> sb;
		int x = ID(sa), y = ID(sb);
		union_xy(x, y);
	}
	int ans1 = 0, ans2 = 0;
//	show(n);
//	forarr(pre, 1, n);
	for(int i=1; i<=n; i++)
		if(pre[i] == i) ans1 ++, ans2 = max(ans2, sum[i]);
	printf("%d %d\n", ans1, ans2);




#ifdef debug
	clock_t etime = clock();
	printf("rum time: %lf 秒\n",(double) (etime-stime)/CLOCKS_PER_SEC);
#endif 
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值