poj 2718 Smallest Difference(dfs枚举水过)

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.
Input
The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.
Output
For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.
Sample Input
1
0 1 2 4 6 7
Sample Output
28



题目大意:给你几个数字,然后你任意组合成两个数字,求这两个数字的差的绝对值的最小值,此题暴力可以水过,不过得选c++,g++不给过= =

还有一个就是注意一下首个数字不能为零的问题。

#include <iostream>
#include <queue>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

int ma[10];int ans1;int num;
int vis[10];
int ans[10];

void dfs(int deep)//参数分别为第一个数为n位数,一共有num个数,当前是deep位
{
    if(deep>num){

            int num1=0,num2=0;
        for(int i=0;i<num/2;i++)
        {
            num1=num1*10+ans[i];
        }
        for(int i=num/2;i<num;i++)
            num2=num2*10+ans[i];
        ans1=min(ans1,abs(num1-num2));
  
        return ;
    }
    for(int i=0;i<num;i++)
    {
        if(vis[i])continue;
        if(num/2>1&&deep==1&&ma[i]==0)continue;
        if(num/2<num-1&&deep==num/2+1&&ma[i]==0)continue;
        vis[i]=1;ans[deep-1]=ma[i];
        dfs(deep+1);
        vis[i]=0;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        char ch;num=0;ans1=99999999;

        while((ch=getchar())!='\n')
        {
            if(ch==' ')continue;
            ma[num++]=ch-'0';
        }
            dfs(1);
        cout<<ans1<<endl;

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值