HDU1829:A Bug's Life(并查集)

Problem Description
Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
 

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
 

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
 

Sample Input
  
  
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
 

Source


参看大神的方法写的,自己的理解用注释标注了,记下来在博客上,注意最后还要加一行,scanf才不会超时

代码:
#include<stdio.h>
#include<string.h>

int n,m;
bool flag;
int father[2005],rank[2005];

void init()
{
	flag=false;
	for(int i=1;i<=n;i++)
		father[i]=i,rank[i]=0;
}

int find(int x)
{
	if(father[x]==x)
		return father[x];
	int t=find(father[x]);//递归找到最顶层的父节点
	rank[x]=(rank[father[x]]+rank[x])&1;//从最顶层一层一层下去
	father[x]=t;//减少层数提高效率
	return father[x];
}

void combine(int a,int b)
{
	int ta=find(a);//找到这两个节点的父节点
	int tb=find(b);
	if(ta==tb)//父节点相同在同一棵树里
	{
		if(rank[a]==rank[b])//判断a,b是否同性
			flag=true;
		return;
	}
	father[ta]=tb;//不在同一棵树里,放到一颗里
	rank[ta]=(rank[a]+rank[b]+1)&1;//如果a,b同性通过改变a的父节点性别来改变b的性别
}

int main()
{
	int t,i,a,b;
	int cnt=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		init();
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			if(flag==true)
				continue;//如果已经证实有错误接下来就可以直接输入不判断
			combine(a,b);
		}
		printf("Scenario #%d:\n",cnt++);
		if(flag)
			printf("Suspicious bugs found!\n\n");
		else printf("No suspicious bugs found!\n\n");

	}
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值