Prime Gap UVA - 1644 水题

  The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and notequal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n.For example, ⟨24, 25, 26, 27, 28⟩ between 23 and 29 is a prime gap of length 6.Your mission is to write a program to calculate, for a given positive integer k, the length of theprime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

InputThe

  input is a sequence of lines each of which contains a single positive integer. Each positive integeris greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end ofthe input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is thelength of the prime gap that contains the corresponding positive integer in the input if it is a compositenumber, or ‘0’ otherwise. No other characters should occur in the output.

Sample Input

10

11

27

2

492170

0

Sample Output

4

0

6

0

114

给一个数,求出距离这个数最近的两个素数的距离。

 无符号整型的素数的最大间隔不超过600吧应该。很水。

#include<bits/stdc++.h>
bool p(int n)
{
    int i;
    int b=sqrt(n);
    for(i=2;i<=b;i++)
        if(n%i==0)
        break;
    if(i>=b+1)
        return true;
    else
        return false;
}
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)&&n)
    {
        int l=n,r=n;
        while(!p(l))
            l--;
        while(!p(r))
            r++;
        printf("%d\n",r-l);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值