SDUSTOJ Problem A: 平面上的点——Point类 (I)

<h2 style="color: blue; font-family: Simsun;">Description</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><p>在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。</p><p>根据“append.cc”,完成Point类的构造方法和show()方法。</p><p>接口描述:
Point::show()方法:按输出格式输出Point对象。</p></div><h2 style="color: blue; font-family: Simsun;">Input</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><p>输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。</p></div><h2 style="color: blue; font-family: Simsun;">Output</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><p>输出为多行,每行为一个点,X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。输出格式见sample。</p><p>C语言的输入输出被禁用。</p></div><h2 style="color: blue; font-family: Simsun;">Sample Input</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><span class="sampledata" style="white-space: pre; background-color: rgb(141, 184, 255); font-size: 18px; font-family: monospace; background-position: initial initial; background-repeat: initial initial;">1,23,32,1</span></div><h2 style="color: blue; font-family: Simsun;">Sample Output</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><span class="sampledata" style="white-space: pre; background-color: rgb(141, 184, 255); font-size: 18px; font-family: monospace; background-position: initial initial; background-repeat: initial initial;">Point : (1, 2)Point : (3, 3)Point : (2, 1)Point : (0, 0)</span></div><h2 style="color: blue; font-family: Simsun;">HINT</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><p></p><p>注意精度控制,C语言的输入输出被禁用。</p><p></p></div><h2 style="color: blue; font-family: Simsun;">Append Code</h2><div class="content" style="height: auto; background-color: rgb(228, 240, 248); margin: 0px; padding: 0px 20px; font-size: 14px; font-family: 'Times New Roman';"><a target=_blank href="http://192.168.119.211/JudgeOnline/append_detail.php?lang=1&pid=1121&getkey=" style="color: rgb(26, 92, 200); text-decoration: none;">append.cc</a>,</div>
#include<iostream>
#include<iomanip>
using namespace std;
class Point{
    private:
    double x;
    double y;
    public:
    Point():x(0),y(0){}
    Point(double a,double b):x(a),y(b){}
    void show()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")"<<endl;
    }
};
int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
    }
    q.show();
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值