POJ-2777 Count Color(线段树)

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43236 Accepted: 13095

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source

POJ Monthly--2006.03.26,dodo

题意:有一块长度为L的板,有T种颜料,一开始板被颜料1染色,现在给出m次操作:①将区间[A,B]内染成颜色C,②查询区间[A,B]内有多少种不同的颜色
题解:第一眼看上去就觉得是成段更新的线段树,先状态压缩一下,我们发现颜色的种类很小,我们可以用二进制保存当前区间内有多少种不同的颜色,例如:二进制中第i位是1则表示
有颜色i,如果是0则表示没有颜色i,这样就可以节省很多空间,pushdown的时候也方便很多.注意(这个地方坑了我一天找bug):题目中说了输入的区间[A,B],A可以大于B的,所以A大于
B时,还要交换A,B的值再进行更新查询

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
#include<set>
#include<functional>
#include<iostream>
#include<math.h>
#include<vector>
#include<string>
#include<stdlib.h>
#define FIN freopen("in.txt","r",stdin);
#define FOUT freopen("out.txt","w",stdout);
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
typedef long long LL;
typedef pair<int,int> PII;
const int maxn = 1e5 + 5;
int T;
int sum[maxn<<2],color[maxn<<2];
void build(int l,int r,int rt){
    sum[rt]=color[rt]=1;
    if(l==r) return;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
void PushUP(int rt){
    sum[rt]=sum[rt<<1]|sum[rt<<1|1];
}
void PushDown(int rt){
    if(color[rt]){
        sum[rt<<1]=sum[rt<<1|1]=color[rt];
        color[rt<<1]=color[rt<<1|1]=color[rt];
        color[rt]=0;
    }
}
void update(int L,int R,int c,int l,int r,int rt){
    if(L<=l&&R>=r){
        sum[rt]=color[rt]=(1<<c);
        return ;
    }
    PushDown(rt);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(R>m) update(L,R,c,rson);
    PushUP(rt);
}
bool ans[31];
void query(int L,int R,int l,int r,int rt){

    if(L<=l&&R>=r){
        for(int i=0;i<T;i++) if((sum[rt]>>i)&1) ans[i]=1;
        return;
    }
    PushDown(rt);
    int m=(l+r)>>1;
    if(L<=m) query(L,R,lson);
    if(R>m) query(L,R,rson);
    PushUP(rt);
}
int n;
void print(int l,int r,int rt){
    if(l==r){
        printf("%d%c",sum[rt],l==n?'\n':' ');
        return;
    }
    int m=(l+r)>>1;
    print(lson);
    print(rson);
}
int main(){
    int m;
    FIN
    while(~scanf("%d%d%d",&n,&T,&m)){
        memset(color,0,sizeof(color));
        memset(sum,0,sizeof(sum));
        build(1,n,1);
        char op[2];
        int a,b,c;
        while(m--){
            scanf("%s",op);
            if(op[0]=='C'){
                scanf("%d%d%d",&a,&b,&c);c--;
                if(a>b) swap(a,b);//注意a小于b时一定要交换
                update(a,b,c,1,n,1);
            }
            else {
                scanf("%d%d",&a,&b);
                int cnt=0;
                if(a>b) swap(a,b);//注意a小于b时一定要交换
                memset(ans,0,sizeof(ans));
                query(a,b,1,n,1);
                for(int i=0;i<T;i++) if(ans[i]) cnt++;
                printf("%d\n",cnt);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值